Crossflow Engine Earthing

28 posts / 0 new
Last post
saundersian
saundersian's picture
Offline
Last seen: 17 hours 8 min ago
Joined: 17/04/2014
Crossflow Engine Earthing

Following on from my Post "Battery Recommendations" all components and connections have been checked and all deemed OK but the problem of  "lethargic" cranking still continues.

I am wondering if I have an earthing problem. The -ve from the battery is earthed direct to a bolt on the bellhousing and the starter motor obviously earths direct on the block. I can find no other relevant earth straps. Is there supposed to be an earth cable from the engine block to the chassis? (I remember on a previous crossflow I had there was another earth cable. I seem to recall it ran from the block/bellhousing to the brake master cylinder mounting bracket - but I may be mistaken on its location).

Any thoughts on the need for such an earth strap and, if so, its location?

Jonathan Kay
Jonathan Kay's picture
Online
Last seen: 36 sec ago
Joined: 17/04/2014

How is the alternator connected to earth?

Jonathan

Jonathan Kay
Jonathan Kay's picture
Online
Last seen: 36 sec ago
Joined: 17/04/2014

1996 Assembly Guide for Ford engines:

Jonathan

ECR
ECR's picture
Online
Last seen: 34 sec ago
Joined: 17/04/2014

With my crossflow the engine earth was as itemised above

Wrightpayne
Wrightpayne's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 17/04/2014

Its probably earthing (poorly) via the accelerator and clutch cables!

saundersian
saundersian's picture
Offline
Last seen: 17 hours 8 min ago
Joined: 17/04/2014

Thanks for the comments. I have located the earth strap from the block to the engine mounting bolt. Removed and all surfaces cleaned. This has improved things, so definitely worthwhile. However, the engine still doesn't crank as fast as I would like. Perhaps I am being too unrealistic in my aspirations.

saundersian
saundersian's picture
Offline
Last seen: 17 hours 8 min ago
Joined: 17/04/2014

Thanks for the comments. I have located the earth strap from the block to the engine mounting bolt. Removed and all surfaces cleaned. This has improved things, so definitely worthwhile. However, the engine still doesn't crank as fast as I would like. Perhaps I am being too unrealistic in my aspirations.

saundersian
saundersian's picture
Offline
Last seen: 17 hours 8 min ago
Joined: 17/04/2014

Thanks for the comments. I have located the earth strap from the block to the engine mounting bolt. Removed and all surfaces cleaned. This has improved things, so definitely worthwhile. However, the engine still doesn't crank as fast as I would like. Perhaps I am being too unrealistic in my aspirations.

Jonathan Kay
Jonathan Kay's picture
Online
Last seen: 36 sec ago
Joined: 17/04/2014

... all components and connections have been checked and all deemed OK...

Does that include bench testing the starter and solenoid?

Jonathan

saundersian
saundersian's picture
Offline
Last seen: 17 hours 8 min ago
Joined: 17/04/2014

Yes, they were checked professionally.

Wrightpayne
Wrightpayne's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 17/04/2014

Is it any different if you connect a second battery with jump leads?