Hazard light relay buzzing.

11 posts / 0 new
Last post
Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014
Hazard light relay buzzing.

I was doing a check of my lights and found all working, except offside cycle wing repeater. The bulb OK.

When I try to press the hazard light switch the lights don't work and the relay buzzes. Any ideas, is it just the relay is knackered?

TIA Stewart

Wrightpayne
Wrightpayne's picture
Online
Last seen: 2 min 32 sec ago
Joined: 17/04/2014

TADTS (at some point)

Just cycle the hazard switch on and off a few times usually does the trick!

Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014
I have tried that in the past on a different 7 and it sorted the hazards and indicators not working. This seems different as the indicators are working, but not the hazards. S
John Vine
John Vine's picture
Offline
Last seen: 27 min 11 sec ago
Joined: 17/04/2014

Have you seen this ancient post?  It may give you some clues.

JV

Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014
Thanks John, that will take some digesting. S
Wrightpayne
Wrightpayne's picture
Online
Last seen: 2 min 32 sec ago
Joined: 17/04/2014

The only fault I've had is the earth cable detaching from the ring terminal inside the headlamp bowl.

Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014

Thanks, I'll try a new flasher relay for starters. S

Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014
Removed the relay and hazard switch and cleaned all the contacts. Hey presto, nearside hazards work, not offside. Repeated the process. Offside now work, but not nearside. Bloody electrics.....
Wrightpayne
Wrightpayne's picture
Online
Last seen: 2 min 32 sec ago
Joined: 17/04/2014

Check one of the connectors isnt pushing out the back of the relay holder.

You're getting warm ;-)

Golf November 10
Golf November 10's picture
Online
Last seen: 13 min 23 sec ago
Joined: 17/04/2014
Thanks, I'll just keep plugging away. Stewart
AnkerB-S
AnkerB-S's picture
Online
Last seen: 19 sec ago
Joined: 14/11/2019

Also, check the three connectors on the alternator. On mine, two of the three were loose. Low voltage as a result of a loose connection can cause all kinds of problems.

Anker Berg-Sonne
Stow, Massachusetts

Old fart pretending that age is just a number

1987 Caterham Super 7 1700 Supersprint
2004 Porsche Boxster S
2009 Mercedes CLK 350 Cabriolet