MBE 9A4 Duratec exhaust backfire deceleration

11 posts / 0 new
Last post
Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014
MBE 9A4 Duratec exhaust backfire deceleration

I have strong backfire from approx 1600 RPM to idle speed when I decelerate down with the clutch engaged. When it reaches 1600 RPM it bangs from the silencer. I know its too much unused fuel getting into the exhaust. There is no difference if the engine is cold or at running temperatures. I did try with changing  settings  in  the fuel map, fuel timing but with no effect on backfire.

Any hint what I should look at, trying to get rid of the popping?

Otherwise the engine runs very fine no issues. Its a Duratec 2.3, SBD TB's, custom exhaust, 260hp.

thks for Your advice

Hanns Per

aerobod
aerobod's picture
Offline
Last seen: 17 min 14 sec ago
Joined: 17/04/2014

I have my fuel cut on throttle site 0 above 3000RPM, then a small amount of fuel from 1750 to 2750RPM, then increasing below 1750RPM:

James

David_Long
David_Long's picture
Offline
Last seen: 1 week 3 days ago
Joined: 17/04/2014

I think that is a fairly common problem with the Duratec that does not use 'direct to head' injection. The SBD throttle bodies use injectors quite a long way up the induction path. That may provide better WOT response and power, but under closed throttle conditions the fuel can take a few cycles to reach the cylinders where it will be too rich and probably unburnt in the exhaust gas.  As this is a delay from the previous throttle state, it is not something that can be mapped out easily. It can be made worse by the ignition timing being retarded on the overrun and providing an ignition source when the exhaust valves are open (i.e. gearbox controllers, traction control).

Not an easy fix but a good competition grade CAT and sealed joints will help reduce, if not cure the problem in the sort term.

Geoff Brown
Geoff Brown's picture
Offline
Last seen: 6 hours 32 min ago
Joined: 17/04/2014

I think as the saying goes "they all do that sir" either moderately or severely depending on the fuel set up?

If the cat is still fitted think of the damage it must be taking.  That is why  cat replacement pipe lets the blue flames & over run noise out......nice!

Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014

thank you for Your feedback

I have direct to head injection and not injection into the TB's, I will test cutting the fuel site at site 0 and report back

 

Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014

aerobod: hat would be Your target Lambda map at site 0?
 

aerobod
aerobod's picture
Offline
Last seen: 17 min 14 sec ago
Joined: 17/04/2014

I haven’t got access to my garage computer as I’m away from home this week so can’t send you a screen shot, but at idle at throttle site 0 it is 0.95, typically stepping up to 1.00 by 2000RPM then disabled with fuel cut (i.e. 0.00) at 3000RPM and above. With my particular tune and the cam overlap on the R400D I have never been able to successfully maintain a smooth idle with a lambda target of 1.00 at idle speeds and revs below 2000RPM or so. My 1.00 lambda target is typically a block between 2000RPM and 5000RPM and throttle site 1 to 8.

Also, I don’t need a catalytic converter on my car to meet the Canadian ‘replikit’ rules, so I don’t have an issue of cat overheating when running rich.

James

Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014

Thank You James I have no cat either. I tested Your fuel site for a short run but it started raining so I had only some 3 Miles.  it still bangs now at lower rpm below 1500. So your fuel map at site 0 had some impact. However I need make a longer testrun.

Could You send me Your chipfile for a comparison? thks Hanns Per

aerobod
aerobod's picture
Offline
Last seen: 17 min 14 sec ago
Joined: 17/04/2014

Hi Hanns Per, unfortunately I’m in Montreal until Thurs night and my garage computer is in Calgary, so I can’t send you a chip file copy until Fri.

James

Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014

thank you this would be great

 

Hanns Per
Offline
Last seen: 4 days 5 hours ago
Joined: 18/04/2014

So I made the att modifications to my fuel map, I run lambda control enabled it go much better however not perfect  but this seem to be normal thks.