Vauxhall engine JPE main fuse

6 posts / 0 new
Last post
Mooresusan12
Mooresusan12's picture
Offline
Last seen: 1 week 17 hours ago
Joined: 16/06/2018
Vauxhall engine JPE main fuse
Can anyone help me locate the main fuse on the above.. I have managed to blow something up after catching the securing metal strap on the battery.. I found the fuse box but not a mention of the main fuse. So currently I have no instruments or ignition.. Many thanks in advance..David
Jonathan Kay
Jonathan Kay's picture
Online
Last seen: 35 sec ago
Joined: 17/04/2014

Private Message sent.

Paul Deslandes
Online
Last seen: 2 min 19 sec ago
Joined: 17/04/2014

As far as I'm aware the Vx engined car looms don't have a main fuse that would kill everything.

Do you still have lights? 

Assuming the battery still has volts on its terminals I'd look for a corroded battery chassis connection that has 'fused'

You'll need a test meter to chase the volts along the loom until you find it.

If you don't have a wiring diagram the 95 build manual is available here.

Paul

Mooresusan12
Mooresusan12's picture
Offline
Last seen: 1 week 17 hours ago
Joined: 16/06/2018
Many thanks to Jonathan and Paul.. Now sorted found the fuse in the engine bay a 15amp along the line set up. As I had no lights or anything I guess it was the first fuse to go.. Much relieved to have it up and running again. Thanks again for the great help and advice from you guys. Bestest regards David Gwatkin
Paul Deslandes
Online
Last seen: 2 min 19 sec ago
Joined: 17/04/2014

Well I'm delighted that you found it David although I can't see any fuses on the wiring diagram for the non JPE Vx engined cars other then those in the main fuse box.  If it's only 15A I'm surprised that it cut off as much as it appears to have done.

Paul

Mooresusan12
Mooresusan12's picture
Offline
Last seen: 1 week 17 hours ago
Joined: 16/06/2018
Hi Paul.. Wanted to thank you for your help.. I think when the fuse went it also tripped the battery cut off switch as I had to reset it.. I'm not at all techi that is clear I think.. This would have accounted for having nothing at all working I guess.. Anyway I know a lot more now than I did.. Thanks again.. Bestest regards David